Förstört min ADP1? Kan inte byta tillbaka SPL eller FW?

Diskussion i 'Dream' startad av n0ir, 3 jan 2010.

  1. n0ir

    n0ir Kid Droid Medlem

    Blev medlem:
    25 dec 2009
    Inlägg:
    73
    Mottagna gillanden:
    5

    MINA ENHETER

    Skrev ett inlägg här https://swedroid.se/forum/showthread.php?t=4633 också, men eftersom topic inte stämmer längre så gör jag ett nytt inlägg (ta bort om det strider mot forumreglerna).

    Jag har en ADP1 som jag tidigare har lyckats uppdatera till FW 1.6 utan problem. Allt fungerade bra med min svenska operatör (Tele2) men eftersom jag ville kunna köra AdFree tänkte jag försöka roota telefonen.

    Jag följde guiden på http://theunlockr.com/2009/10/15/how-to-root-a-donut-phone-android-1-6/, närmare bestämt första delen http://theunlockr.com/2009/07/05/how-to-unroot-your-t-mobile-g1/ där man ska downgrada till FW 1.5.

    Jag installerade original SPL samt original DreaIMG.nbh innan jag uppdaterade med FW 1.5 ("signed-kila-ota-148830.de6a94ca.zip").

    Nu i efterhand har jag förstått att denna FW är för T-mobile och inte för ADP1 (som istället, enligt HTC:s hemsida på http://developer.htc.com/adp.html, ska ha en FW som heter "signed-dream_devphone_userdebug-ota-150275.zip" för ADP1 FW 1.5).

    Dessvärre innebär detta att jag nu har en ADP1 med T-mobile OS, vilket gör att telefonen verkar låst till denna operatör. När jag startar telefonen så får jag fram den vanliga inloggningsskärmen där man fyller i användarnamn och lösenord till sitt Google-konto. Det fungerar dock inte att logga in, trots at jag har ändrat APN-inställningarna till Tele2. Antar att telefonen nu bara fungerar med T-mobile SIM-kort?

    OK, tänkte jag, bäst att återställa till den ursprungliga engineering SPL (HBOOT-0.95.3000) och FW 1.6 för ADP1 ("signed-dream_devphone_userdebug-ota-14721.zip") men nu går inte detta!

    När jag försöker uppdatera till ADP1 FW 1.6 får jag felmeddelandet:

    -- Installing from sdcard...
    Finding update package...
    Opening update package...
    Verifying update package...
    E:No signature (412 files)
    E:Verification failed
    Installation aborted.


    Eftersom jag nu också får T-mobile boot screen och rainbow fastboot screen så tänkte jag at det är p.g.a. att jag nu sitter med original SPL och först måste byta tillbaka till engineering SPL. Det går dock inte heller! Jag får bara felmeddelandet:

    -- Install from sdcard...
    Finding update package...
    Opening update package...
    Verifying update package...
    E:No signature (5 files)
    E:Verification failed
    Installation aborted

    Varför kan jag inte byta från gå från original SPL (HBOOT-0.95.0000) till Engineering SPL (HBOOT-0.95.3000) eller HardSPL (HSPL10.95.3000)?

    Borde det inte bara var att lägga in den önskade SPL-filen (t.ex. HBOOT-0.95.3000) på minneskortet, döpa om den till "update.zip", starta telefonen i recovery med home+end och installera den med Alt+S?

    Finns det någon ADP1 DreaIMG.nbh-fil som jag kan försöka med? Hittar ingenting när jag letar?

    I SPL-menyn på telefonen (kamera+end) så ser det ut så här i dagsläget:

    DREA110 PVT 32B
    HBOOT-0.95.0000
    CPLD-4
    RADIO-2.22.19.26I

    Hjälp! :(
     
  2. n0ir

    n0ir Kid Droid Medlem

    Blev medlem:
    25 dec 2009
    Inlägg:
    73
    Mottagna gillanden:
    5

    MINA ENHETER

    Lyckades i.a.f ta mig förbi Google-kontoinloggningen!

    Det visade sig vara avsaknaden av 3G-nät som spökade (man var tvungen att skriva in Proxy 130.244.196.090 och Port 8080 för internet-delen i APN-inställningarna man når med meny-knappen innan inloggningen så att telefonen kunde logga in med GPRS, trots instruktionerna i Wiki:n som säger annorlunda https://swedroid.se/wiki/index.php/APN-inställningar).

    Nu kan jag alltså logga in i telefonen och i "About phone" har jag följande information:

    Model number: T-Mobile G1
    FW: 1.5
    Baseband version: 62.50S.20.17H_2.22.19.26I
    Kernel version: 2.6.27-00393-g6607056 [email protected] #1
    Build number: CRB43
     
  3. n0ir

    n0ir Kid Droid Medlem

    Blev medlem:
    25 dec 2009
    Inlägg:
    73
    Mottagna gillanden:
    5

    MINA ENHETER

    Hmm...

    Genom att följa guiden på http://forum.xda-developers.com/showthread.php?t=442480 (först downgrada till RC29 så jag fick tillgång till konsolen och kunde köra telnetd, och sedan flasha med recovery.img) så kunde jag till slut lyckas byta till en annan SPL (det blev Hard SPL, HBOOT-0.95.3000)!

    Pust.

    Nu verkar det alltså som om jag har en rootad G1:a med T-mobile FW 1.0 och Hard SPL.

    Vilken moddad FW vill jag nu installera? Jag vill ju ha en FW 1.6 men det verkkar finnas flera olika som man kan använda sig av?
     
  4. blunden

    blunden Professional Droid Hedersmedlem

    Blev medlem:
    11 jun 2009
    Inlägg:
    2 878
    Mottagna gillanden:
    287
    Telefon:
    OnePlus 7 Pro

    MINA ENHETER

    Telefon:
    OnePlus 7 Pro
    Telefon 2:
    Xiaomi Mi MIX
    ROM:
    LineageOS 16.0
    Telefon 3:
    Nexus 5
    ROM:
    LineageOS 14.1
    Platta:
    LG G Pad 8.3
    ROM:
    LineageOS 14.1
    Övrigt:
    Huawei Watch, Moto 360, Nvidia Shield TV, Honor View 10
    Jag skulle föreslå CyanogenMod. Finns en wiki här.